Start a new topic

Crashing after Upgrade to Windows 10

 After I had upgraded my system to Windows 10 octgn fails to load. It always crashes as it is loading before I get to the login screen. I have tried to uninstall then reinstall which did not change anything. Attempting to run the program in compatibility mode did nothing either. I took a look at the log and while I do not understand most of it I noticed a reference to the game database folders I had installed among the errors and tried removing them to see if that did anything. It kept those same errors from appearing in the log but did not prevent the crashing. I restored the folders and reran the program with the same crashing.

My specs are:
AMD Phenom II X6 Processor
Radeon HD 5700 Graphics card
8 GB Ram
.NET Framework v4.0.30319
I am running the x64 version of Windows 10 Pro

If I need other specs I can post them. The log file is attached.

txt
(95.6 KB)

1 person has this problem

sorry nobody's gotten to you, but I think everybody's about as baffled as you when they look at those logs... or at least I am. I would recommend renaming your USER_NAME\octgn folder and installing it fresh and see if you still get the same problem. if that doesn't fix it you can simply delete the new octgn folder and restore you old folder to it's original name, if it does fix it, you may just have to set up octgn again.


I suspect something happened in the process of upgrading that is causing issues for some files in there, and not necessarily the ones that are actually turning up on the log. sorry that's the best I've got for you.

I did a little research and found that the main error I was looking at (This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms) concerns how Windows enforces the FIPS standard for software. There appears to be several programming specific sites where people have run into this issue.


I am not sure exactly why I would be having this issue and not others who are running Windows 10 (unless some of the other crashing issues are related). However I found the registry entry to change if you want to turn off the enforcement of FIPS. As soon as I made the change OCTGN loaded correctly. So far it appears to be working fine just now.


Here is the Registry entry I changed.


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\FIPSAlgorithmPolicy


Just change the enabled option to 0 instead of 1.

Login to post a comment