Start a new topic

Game Definition and Deck Editor issues

Hi all.


I've just recently made a (really sparse) game definition to play test a game me and my friends are working on. It doesn't have many scripts attached to it, but I've been able to make the .nupkg file using o8build. I've also managed to make a the set.xml for a test set.


Issue is. When I do put the .nupkg file into the LocalFeed folder and install the game on OCTGN, starting the game gives me "You have been disconnected from the game. Please wait while we reconnect you." while trying to make a new deck for the game on the deck editor gives me "There was an error. Try restarting!"


I've tried looking through my .xml files and trying to find coding mistakes, but I'm at a loss at what to do now. I thought it'd run smoothly when the .nupkg file was made, but I guess I was wrong.


I've attached the game development file which contains the .xml files, folders and the .nupkg file. Any help I can get is greatly appreciated.


Thanks!


I've also attached the log file which shows both errors. I have no idea how to interpret them because I am horrible at C#.


PS: I know that the <script> </script> section in definition.xml is empty when the file makes references to .py scripts. I've already added the script source in already, and it still doesn't work.

zip
txt
(36.2 KB)
1 Comment

The resolution for this was removing the font elements from the game definition.

Login to post a comment