Start a new topic

OCTGN and Windows Freeze

About half of the Netrunner games that I play are cut short when both the program and Windows freeze. So far, every game that I have been playing was as the Corp. Once the freeze happens, I can sometimes still hear the opponent performing actions in the background, but there are no changes to the interface/GUI. Both OCTGN and Windows become completely unresponsive. I then try Ctrl+Alt+Del, which does bring up the Windows Security Menu. After selecting Task Manager the screen goes completely black and stays that way. I am never able to access Task Manager. Pressing random keys does result in sounds from OCTGN sometimes, but clicking around randomly never does. I have also tried waiting several minutes immediately after the freeze but the system never recovers. I am forced to restart in order to use the PC again. Before putting in this ticket I did uninstall Netrunner in OCTGN, then a complete uninstall including a rename of the OCTGN directory in Documents. I also cleared the Registry using CCleaner. Finally, I reinstalled the current version of OCTGN and reinstalled Netrunner. The frequency of the issue has not changed since the troubleshooting steps. Has any one else run into this issue before? Any ideas on what other troubleshooting steps can I take? Version: 3.1.149.334 (Current Stable) Game: Netrunner LCG Thank You, lynx

1 person has this problem

Just want to report back that I haven't had Windows freeze even once since I unchecked "Use Window Transparency" and "Use Hardware Rendering".  Next, I'm going to disable EMET to see if this improved behavior continues.
@yeleeknad - Good call on the "Use Window Transparency" and "Use Hardware Rendering" settings. I do remember turning those off when initially troubleshooting the issue and I never turned them back on. They could be part of the issue, but most often they are settings to adjust when running OCTGN from within a virtualized copy of Windows. Hopefully that will do it for you, but I think of anything else I'll post it.

@illusionistlynx, thanks for sharing that.  They seemed out of place, but if I'm not the only one then ok!


I'm running OCTGN on 64-bit Windows 7 with 8 GB RAM and a 3.8 GHz quad core AMD processor.  It's the only program that causes my computer to freeze up this way.  When it happens, I hit Ctrl+Alt+Delete and Switch User, log in with a different account, open Task Manager, log off the 1st account running OCTGN, and then log back in with the 1st account.  Relaunching OCTGN at that point works fine.  (I figured this was better than powering my computer off with the physical power button each time it froze while running OCTGN.)


Yes, EMET appears to be configured as you described.


After posting my previous comment, I went into OCTGN Options and unchecked "Use Window Transparency" and "Use Hardware Rendering" to see if that makes a difference.  I played a few games for a couple of hours, and it didn't freeze - but it wasn't long enough of a test to know if the Options changes really had any effect.

jpg
(105 KB)
@yeleeknad - It may seem strange, but that's normal for the log files. While I cannot say why those references are there, I can attest that they have been in all of my log files since I started checking. Can you give my some additional information about your setup and Operating System (XP, Vista, Windows 7/8/8.1/10)? Also, can you verify that EMET is configured as described here: Make sure DEP, ASLR and SEHOP are set to Application Opt In. Click on Apps in the Configuration section of the Ribbon bar and then check every single option to the right of OCTGN.
I've been experiencing the same problem illusionistlynx described, but the EMET solution isn't preventing it from continuing to occur.  I found these strange references to non-existent directory "C:\Program Files (x86)\Jenkins\..." in the log files.  Any thoughts on whether this could be related to the problem and/or how to resolve it?

WARN 2015-04-12 20:28:47,887 3.1.160.353 [1] Octgn.Program [(null)] - Check desktop experience error. An error like 'Not Found' is normal and shouldn't be worried about
System.Management.ManagementException: Not found
at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)
at System.Management.ManagementObject.Initialize(Boolean getObject)
at System.Management.ManagementBaseObject.get_wbemObject()
at System.Management.ManagementBaseObject.get_ClassName()
at System.Management.ManagementClass.GetInstances(EnumerationOptions options)
at Octgn.Program.Start(String[] args) in c:\Program Files (x86)\Jenkins\workspace\OCTGN-Release\octgnFX\Octgn\Program.cs:line 251

WARN 2015-04-12 21:06:47,034 3.1.160.353 [26] Octgn.Networking.ClientSocket [(null)] - EndReceive
System.NullReferenceException: Object reference not set to an instance of an object.
at Octgn.Library.Networking.SocketBase.EndReceive(IAsyncResult res) in c:\Program Files (x86)\Jenkins\workspace\OCTGN-Release\octgnFX\Octgn.Library\Networking\SocketBase.cs:line 157

WARN 2015-04-13 08:29:52,061 3.1.160.353 [1] Octgn.Play.Gui.GroupControl [(null)] - UpdateYCenterOffset Error
System.InvalidOperationException: The specified Visual is not an ancestor of this Visual.
at System.Windows.Media.Visual.TrySimpleTransformToAncestor(Visual ancestor, Boolean inverse, GeneralTransform& generalTransform, Matrix& simpleTransform)
at System.Windows.Media.Visual.InternalTransformToAncestor(Visual ancestor, Boolean inverse)
at Octgn.Play.Gui.TableControl.<UpdateYCenterOffset>b__12() in c:\Program Files (x86)\Jenkins\workspace\OCTGN-Release\octgnFX\Octgn\Play\Gui\TableControl.xaml.cs:line 676

That's how it's set up. Worked like a charm.

@Hodor: Indeed it is. I hope this works for you as well, and I totally agree about the MS site.

It is always nice to see a thread where someone had, and subsequently solved, the very technical issue you are having.

Hopefully this works. I'm still trying to load the microsoft site. How does a company like Microsoft get by with such a poor web design team?

Make sure DEP, ASLR and SEHOP are set to Application Opt In. Click on Apps in the Configuration section of the Ribbon bar and then check every single option to the right of OCTGN. Some of them I'm sure are not necessary but I just checked them all before tested which is what worked for me.

Alright I installed EMET 5.0 and added OCTGN in the Apps section with the default options. Was there anything else you did in EMET?

If it is as simple as installing EMET and adding OCTGN to the list of managed apps then I should be good, but I will let you know otherwise.

I was finally able to resolve this issue by installing Windows EMET (Enhanced Mitigation Experience Toolkit) and then adding OCTGN to the list of managed applications. This does DEP, ASLR and SEHOP to prevent various issues with programs causing Windows to fail. This would suggest that OCTGN has problems with how it stores/accesses memory.


Mrcclassical: If you need help with this solution please let me know and I can type something up for you. 

I am having a very similar issue when playing Lord of the Rings LCG

Login to post a comment